Martin User Forum (closed)
Martin User Forum (closed)
Home | Profile | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
 All Forums
 Controllers
 M2GO/M2PC/M-TOUCH Hardware
 Windows Crashing and Mcpc Freezing
 Forum Locked
Author Previous Topic Topic Next Topic  

bobbythedog

32 Posts

Posted - 15 Dec 2012 :  01:18:56  Show Profile
I am having a issue with m2pc. Yesterday I was on a gig and the controller froze a few time having to wait a couple of mins for it to unfreeze. also twice I had to restart MPC cause it was not responding.

We are running it on a HP Touch Smart 610. Windows 7 Professional.

In had a issue when installed mpc. i could not creat, move or delete a cuelist icon. so i changed the compatibility to windows xp service pack 3. that fixed that issue.

But now its freezing and not reponding.


Does anyone have any clues?


Thanks

Hi-Lights

164 Posts

Posted - 15 Dec 2012 :  09:54:13  Show Profile
Hi,

Two things you could check are that you have UAC turned off and if the usb power saving options are disabled.

Cheers
Go to Top of Page

Paul Pelletier

10024 Posts

Posted - 15 Dec 2012 :  17:42:20  Show Profile
In the hardware device manager of windows, find the USB section and for each sub entires check if the power management is disabled.
i
I suspect the USB connection is dropped by the pc.
Go to Top of Page

bobbythedog

32 Posts

Posted - 23 Feb 2013 :  01:14:06  Show Profile
its still freezing. mostly when editing a kinda of large cue. freezes for a few secs then loads the cue. the m2pc and pc freezes.

Does it matter which version of windows it runs?
I am running Windows 7 Home Premium Service Pack 1 64 Bit
Intel I5-2500 Cpu @ 3.30GHz
6GB of Ram.


Thanks
Go to Top of Page

Ofer Brum

6911 Posts

Posted - 23 Feb 2013 :  08:40:20  Show Profile
Make sure the M2PC is not connected to a USB 3.0 port...
Go to Top of Page

bobbythedog

32 Posts

Posted - 23 Feb 2013 :  09:06:31  Show Profile
this pc doesnt have any usb 2.0 ports
Go to Top of Page

Ofer Brum

6911 Posts

Posted - 23 Feb 2013 :  11:57:40  Show Profile
This may be the cause for that issue

We recently encountered a problem with a big installation ran by M2PC, where the wing was accidentally connected to the USB 3.0 port, which caused a delay issues

Martin are aware of this (Paul actually came up with the idea the USB 3.0 is to blame) matter. Try connecting a USB 2.0 hub, and see if that helps
Go to Top of Page

bobbythedog

32 Posts

Posted - 23 Feb 2013 :  21:35:53  Show Profile
would it help if i re install windows 7 professional. instead of having home prem?
Go to Top of Page

Ofer Brum

6911 Posts

Posted - 23 Feb 2013 :  22:07:16  Show Profile
As far as my understanding goes, no.

We saw a similar issue using Win 7 Pro 64bit...
Go to Top of Page

Paul Pelletier

10024 Posts

Posted - 24 Feb 2013 :  02:32:22  Show Profile
It is a very difficult one to tackle, It's not that we haven't tried to replicate it, but we have yet to get it happen on our PC.

I will be in Belgium next week and I will definitely try to replicate it again.

One thing for sure is that USB 3.0 hardware drivers are not all created equal and still very young... so I would avoid any USB 3.0 for now.
Some BIOS allow you to set these 3.0 in 2.0 mode.
Go to Top of Page

bobbythedog

32 Posts

Posted - 24 Feb 2013 :  04:36:38  Show Profile
ok. but i dont get it. this computer is HP Touchsmart 610-1220a. They don't have any usb 3.0 ports. just 2.0. I will try connecting a external usb 2.0 hub this week and see if it helps.

Thanks
Go to Top of Page

bobbythedog

32 Posts

Posted - 01 Mar 2013 :  01:45:41  Show Profile
so i have tried a usb 2.0 hub thats got a external power supply and its still lagging. if i unplug the m2pc and use maxxyz pc to change stuff it works find. but when i replug it starts to lag again.

Is there anything else i could try?
Go to Top of Page

Ofer Brum

6911 Posts

Posted - 01 Mar 2013 :  06:21:12  Show Profile
Hi,

You wrote earlier, your PC does not have any USB 2.0 ports, so I assumed you only have USB 3.0...

This issue is very serious. We are now getting more and more calls, reporting this matter

The cause for this matter is now shifting toward Windows OS. We have a customer, who ran M2PC for months, using Win XP Pro, with no issues
As soon as he shifted (same PC) to Windows 7 64 bit, he started to experience the same lagging & freezing issues. He now installed Windows 7 32 bit, and the system seems to handle better
Go to Top of Page

bobbythedog

32 Posts

Posted - 02 Mar 2013 :  09:24:15  Show Profile
http://support.microsoft.com/kb/976972?
Go to Top of Page

bobbythedog

32 Posts

Posted - 22 Apr 2013 :  00:35:27  Show Profile
so i've been told that its still freezing. i'm going to check it out on wedensday and see if i can get it to freeze again.

If it does i will post on here again.
The computer has been recently been re formatted with 32 bit windows 7.
But i'm still pretty sure it doesnt have usb 3.0.


Thanks Guys
much appreciated
Go to Top of Page

Paul Pelletier

10024 Posts

Posted - 22 Apr 2013 :  02:01:37  Show Profile
Several changes have been made in for the next release. We are fixing the final details before going public.

Go to Top of Page

bobbythedog

32 Posts

Posted - 22 Apr 2013 :  02:50:28  Show Profile
do u know when the release is?
Go to Top of Page

slightco

39 Posts

Posted - 26 Apr 2013 :  03:35:22  Show Profile
Hi Reuben,
Can you confirm this is the same machine that I had Gavin turn off the UAC and if it is all working now.
Go to Top of Page

bobbythedog

32 Posts

Posted - 26 Apr 2013 :  06:53:37  Show Profile
it seams to be working fine now. still need to street test it. but we will try 64 bit again once the next version comes out.
Go to Top of Page

bobbythedog

32 Posts

Posted - 27 Apr 2013 :  07:46:26  Show Profile
its still freezing and crashing. yes glenn this is the same pc.
Go to Top of Page

kracklow

4 Posts

Posted - 10 Jun 2013 :  17:00:57  Show Profile
Guys, when preparing the Windows PC for an M2PC setup, is it recommended to use Windows 7 32 bit or 64 bit OS? Also what should the patch level be? Should it be SP1 and then all Microsoft updates on top of that or do you prefer a limited set of MS-Updates?

The reason I ask is we purchased two M2PC's and are running the software on a pair of Mac Mini's and we are seeing various lockup or crashing issues during live shows. One system has an issue with the M-PC software crashing and the other tends to stop sending DMX and the M2PC becomes unresponsive, we have to restart the M-PC software to get things going again.

I am rebuilding the one that crashes on a regular bases this week and want to make sure I get the Windows 7 OS on there setup per your recommendations.
Go to Top of Page

Administrator

3932 Posts

Posted - 10 Jun 2013 :  18:31:41  Show Profile
Hi!

Use 64bit and Service Pack 1.
The issue you describe are due to USB traffic hang ups, which are resolved with Version 3.0 and a new firmware for the hardware.
Go to Top of Page

kracklow

4 Posts

Posted - 10 Jun 2013 :  18:35:19  Show Profile
Thanks for the quick reply, what about updates beyond SP1 should we apply those or stop with SP1?
Go to Top of Page

kracklow

4 Posts

Posted - 10 Jun 2013 :  18:39:56  Show Profile
Oh and do you have an estimated ship date for 3.0?
Go to Top of Page

Administrator

3932 Posts

Posted - 10 Jun 2013 :  19:14:56  Show Profile
You can apply all available Windows Updates.
Version 3.0 was released last week: http://www.martin.com/controllersupport/

Go to Top of Page

samuel ball

12 Posts

Posted - 11 Jun 2013 :  09:01:58  Show Profile
What firmware version should I have on my m2pc?
Go to Top of Page

Paul Pelletier

10024 Posts

Posted - 11 Jun 2013 :  14:35:30  Show Profile
M2GO/M2PC Firmware 2.31 is available with version 3.0.

Go to Menu/System/Tools/Diagnostic and press Firmware update.
Go to Top of Page

kracklow

4 Posts

Posted - 16 Jun 2013 :  21:08:23  Show Profile
Paul/Matthias,

After rebuilding our two Mac Mimi's with Windows 7 x64 and the latest M-series software and M2GO firmware, we are seeing much more stable lighting desks. Thanks!
Go to Top of Page
  Previous Topic Topic Next Topic  
 Forum Locked
Jump To:
Martin User Forum (closed) © 2017 Martin Professional Go To Top Of Page
Snitz Forums 2000