Martin User Forum (closed)
Martin User Forum (closed)
Home | Profile | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
 All Forums
 Controllers
 M2GO/M2PC/M-TOUCH Hardware
 New M-Touch Appears Dead (Solved)
 Forum Locked
Author Previous Topic Topic Next Topic  

WindWorks

19 Posts

Posted - 18 Oct 2015 :  05:47:03  Show Profile
I just received my new M-Touch this week from my local dealer. Plugged it in and Windows said the driver was successfully loaded. But the M-Touch had lights and appeared dead. I launched M-PC, loaded the the demo show file (I'm new to M-PC), and the M-Touch still has no lights and appears to be dead. In the setup menus of M-PC, the M-Touch does not show as an available device.

Am I doing something wrong, or it the unit dead?

vaspet

92 Posts

Posted - 18 Oct 2015 :  10:04:09  Show Profile
Try uninstalling the software with the martin cleanup tool http://forum.martin.com/topic.asp?TOPIC_ID=22979
And then install the latest version .604. That worked for me.
Go to Top of Page

Ofer Brum

6911 Posts

Posted - 18 Oct 2015 :  11:42:51  Show Profile
Are you using M-PC 604?
Which menu did you look at? The unit will appear under System\DMX Settings\ USB DMX
Go to Top of Page

WindWorks

19 Posts

Posted - 18 Oct 2015 :  22:24:28  Show Profile
Thank you both. The software was not .604. We un-installed and re-installed M-PC with the latest software and it is working fine. Thank you again.
Go to Top of Page
  Previous Topic Topic Next Topic  
 Forum Locked
Jump To:
Martin User Forum (closed) © 2017 Martin Professional Go To Top Of Page
Snitz Forums 2000