Martin User Forum (closed)
Martin User Forum (closed)
Home | Profile | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
 All Forums
 Other
 Non-Controller related topics
 Roboscan 812 no power
 Forum Locked
Author Previous Topic Topic Next Topic  

euromix

3 Posts

Posted - 07 Aug 2014 :  01:44:33  Show Profile
Hi I have had my roboscans in storage for the past 3 years. 3 out of the 4 work, 1 has no power at all. I checked the fuse and it is fine. Any help would be great.

Leonard

31 Posts

Posted - 07 Aug 2014 :  20:35:17  Show Profile
Hey there,

I have worked on the roboscan line for a while dealing with everything between the 1220,518,218 and the little 812. fixing them for DJ's and local night clubs. There could be lots of problems. Lets pin point this:

Did that fixture that was not powering up power at all?
(did it start-up for a second then stop)

Did you check all the fuses?
(if I recall there is a fuse on the circuit board as well, with that being said opening that light may get a bit dicey. I'll give you tips if we need to go down that path.)

Did the fan power up?

Open circuit will be the last thing to check.
(This happens when 1 or more leads that carry power is open)

Are you running them in 110V-120V or 208v-220v?

The more info you can give me the better. Lets keep the old lights alive!![:D]



Go to Top of Page
  Previous Topic Topic Next Topic  
 Forum Locked
Jump To:
Martin User Forum (closed) © 2017 Martin Professional Go To Top Of Page
Snitz Forums 2000